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Format Conventions 

In this document the following format conventions are used: 

Commands that you must type in are shown 
in bold� Courier font. 

My� Site 

Menu items and keys you press are given in a 
Bold, Arial font. 

Windows Applications 

Feedback 
If you notice any mistakes in this document please contact the Information Officer.  
Email should be sent to the address info-officer@leeds.ac.uk   

Copyright 

This document is copyright University of Leeds. Permission to use material in this 
document should be obtained from the Information Officer (email should be sent to 
the address info-officer@leeds.ac.uk) 

 

Print Record 
This document was printed on 17-Jun-03. 
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Task 1 Getting Started with Dreamweaver 
Objective To become familiar with the Dreamweaver MX workspace. 

Instructions You will open Dreamweaver and familiarise yourself with the 
windows, toolbars and menus. 

Comments Dreamweaver MX can look daunting but is easy once you know your 
way around. 

 

Activity 1.1 Open Dreamweaver by Selecting Start Menu -> Programs -> Internet 
Tools -> Dreamweaver.   The screen should appear as shown in 
Figure 1. 
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The Document Window 
The Document window displays the current document. The document 
can be displayed approximately as it will appear in the web browser 

by clicking the Show Design View button   in the top left-hand 
corner of the document window. Alternatively, the HTML source of the 
current document can be shown by clicking the Show Code View 

button , or both souce and design views be shown by clicking the 

Show Code and Design Views button . The estimated download 
time of the page is given at the right-hand side of the status bar.  The 
menu bar is discussed below. 

The Menu Bar 
Dreamweaver has ten main menus on the menu bar of the Document 
window.  The menus follow the standard Windows format of having 
File and Edit on the left and Window and Help on the right.  The 
menus are described in detail below: 

File 
The File menu deals with all the file-handling aspects of Dreamweaver such as 
opening, saving and creating new files or sites.  This menu also contains data 
handling commands such as the importing, exporting, and converting of documents.  
Link-checking and previewing of pages in browsers are also available commands.  
Finally the command to quit Dreamweaver is here. 

Edit 
The Edit menu contains commands for undoing/redoing actions, cut, copy, paste, 
and find and replace.  It also contains the preferences command which allows you to 
alter your own Dreamweaver set-up. 

View 
The View menu alters the display attributes, such as whether gridlines are 
displayed, or certain palettes or borders are showing. 

Insert 
The Insert menu contains commands to insert various objects such as those 
contained within the Object palette (see later), line breaks, etc. 

Modify 
The Modify menu contains commands for modifying various objects such as tables, 
frames, etc., as well as for altering links and the page properties. 

Text 
The Text menu contains the text formatting commands such as font size, colour, 
type, alignment, etc. 

Commands 
The Commands menu contains the commands for cleaning up the HTML, applying 
source formatting, etc. 

Site 
The Site menu allows you to work with sites you have defined (see section 2). 
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Window 
The Window menu is a series of commands which allow you to select the various 
windows and floating palettes or inspectors you may need to view. 

Help 
The Help menu allows you to launch the Macromedia Dreamweaver Help Pages in 
Internet Explorer.  The Help system is very comprehensive, if a little difficult to use 
initially. 

The Dreamweaver MX workspace 
The Dreamweaver has one main window which contains the current HTML 
document together with some sub-windows (or panes). These panes are described in 
further detail below.  Other inspectors, such as Layers and Frames, are available 
from the Window menu but will not be discussed here. 

Insert pane 
The Insert Pane,  seen immediately above the document window, contains buttons 
for creating various types of objects such as images, tables, layers, and so on. 
Various categories of object are available in separate tabs, which are selected by 
clicking on the appropriate category tag name.   

Property Inspector 
The Property Inspector displays properties for a selected object such as font type, 
font size, link URL, etc. 

Activity 1.2 Familiarise yourself with the menu choices, buttons, etc., by using 
the mouse – ‘hovering’ the cursor over the buttons on the 
palettes/inspectors will show a brief description of what each one 
does. 

Activity 1.3 Minimise the Property Inspector as it will not be used for most of this 
work. 

Design 
Gives you detailed information about the HTML, CSS and Javascript on the current 
page. 

Code 
Tag Inspector tab provides details of the structure of the HTML  page and enables 
you to select HTML objects in the document window. The Snippets tag shows a 
library of ‘HTML snippets’, sections of HTML such as footers etc, which can be 
inserted into the HTML page. 

Application 
The Application window is used when developing a web server application in 
technologies such as ASP or PHP. 

File 
This pane gives you access to the information about the Site you are working with. 
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Task 2 Creating a Local Site 
Objective To create a local site. 

Instructions You will create a local site using the New Site command. 

Comments Dreamweaver’s Site window helps manage a website easily.  This is a 
very brief introduction: further information should be gleaned from 
the Help system. 

 

Activity 2.1 From the File menu in Document window of Dreamweaver choose 
New Site. 

Activity 2.2 In the Site Definition dialog box, select Local Info from the Category 
list. 

 

 

Figure 2  Site Definition dialog box 

 

Activity 2.3 Enter a Site Name, such as My� Site. 

Activity 2.4 Choose a local directory as the Local Root Folder. 

Activity 2.5 Click OK. 
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Note The File pane, shown in Figure 3, can be used for viewing local and 
remote sites, adding or removing site documents, or for 
storyboarding.  The window consists of two panes, a splitterbar, a 
menu bar, and certain buttons.  Any changes to the File pane will 
remain in place even after it has been closed and re-opened. 
By default, only the local files are shown in the file pane. To see the 
full site view, including remote files on the webserver, click the 

Expand/Collapse  button in the File pane. 

Site management is beyond the scope of this document.  For more information see 
the Dreamweaver Help Pages. 

 

 

Figure 3  The Site window 
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Task 3 Creating A Simple Table 
Objectives To create a simple table with borders and headers. 

Instructions You will insert a table into your HTML page from the Insert Pane. The 
table will make use of the following tags- <TABLE>,� <CAPTION>,�
<TR>,� <TH>� and <TD>. 

Comments The insert table option in the Insert Pane is used to create initial table 
templates.  The more advanced table attributes cannot be applied to 
your table at this stage.  You will normally use this option to create a 
simple table using the default settings and then modify it afterwards. 

 

Activity 3.1 Enter an appropriate title for your HTML document. e.g., Creating�
Tables� with� Dreamweaver.  Right Click on the document window 
Design View and select the option Page Properties…. Type the title 
into the Title: text box in the Page Properties dialog box. Click OK in 
this dialog box and then save your document into the directory you 
created in Task 2 

Activity 3.2 You will now insert a table template using Dreamweaver’s Insert 

Pane.  Click on the Insert� Table icon  on the Common tab of the 
Insert Pane tool bar. (If the Insert Pane is currently minimised, click 
the on the Insert Pane title.)  The following dialog box will appear. 

 
 

Figure 4  Insert Table dialog box 

The dialog box gives you the options to set six of the most important 
table definition attributes. Create a table with 3 rows, 4 columns, a 
width of 70% and a border of 2 pixels. (Cell Padding defines the width 
in pixels between the edge of a table cell and its' contents. Cell 
Spacing defines the width in pixels between individual table cells. 
These attributes gives extra control over the appearance of a table.) 

Click� OK. 

You will now see the table template in your document window in 
Design View. 
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Activity 3.3 In the document window click the Show Code View button .  This 
will open the Code View which shows all the HTML code in the 
document. Click on the body of the Code View to give it the focus, at 
which point it has a white background which indictates that it is 
ready for editing. At present the only code present is that 
automatically generated by Dreamweaver upon opening a new 
document, and also the HTML generated when you inserted a new 
table from the object palette, as shown in Figure 5. 

 

Figure 5  Automatically generated HTML code 

 

The following HTML tags will be inserted into your document. 
<table� width="70%"� border="2">�
� � <tr>�
� � � � <td>&nbsp;</td>�
� � � � <td>&nbsp;</td>�
� � � � <td>&nbsp;</td>�
� � � � <td>&nbsp;</td>�
� � </tr>�
� � <tr>�
� � � � <td>&nbsp;</td>�
� � � � <td>&nbsp;</td>�
� � � � <td>&nbsp;</td>�
� � � � <td>&nbsp;</td>�
� � </tr>�
� � <tr>�
� � � � <td>&nbsp;</td>�
� � � � <td>&nbsp;</td>�
� � � � <td>&nbsp;</td>�
� � � � <td>&nbsp;</td>�
� � </tr>�
</table>�

 

The &nbsp;� seen above is the HTML code for a nonbreaking space. 
Dreamweaver inserts this into empty cells because some browsers 
collapse the cell without it. 
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Activity 3.4 Give the table a caption "Simple Nouns" aligned at the top of the 
table. You will use the tags <caption>…</caption> which should be 
placed after the <table> tag. 

Activity 3.5 Add an extra row to the table, defining the cells in the new row to be 
table header cells rather than table data cells. The four headings will 
be:  English, German, French, Italian, i.e., you will need to add the 
following HTML: 

<tr> 
   <th>English</th> 
   <th>German</th> 
   <th>French</th> 
   <th>Italian</th> 
</tr> 

Insert the following data between the DATA� tags <td>...</td>. 

For row 2 insert  window,� fenster,� fenêtre,� finestra.�

For row 3 insert� man,� mann,� homme,� uomo.�

For row  4 insert morning,� morgen,� matin,� mattina 

Activity 3.6 View the changes to your document in Netscape by Selecting  
Preview in Browser option from the File menu. Your table should 
appear as follows. 

 

Explanation The <TABLE>...</TABLE> tag encloses the whole table.  The table is 
displayed with a border if the attribute BORDER is present in the 
<TABLE> tag. 

 The <CAPTION>...</CAPTION> tag defaults to the centre of the top of 
the table.   
 

 The <TR>...</TR> tag defines a table row. 
  

The <TH>...</TH> tag defines a column or row header.  The default 
text alignment is CENTER and the header is formatted in bold. 

  
The <TD>...</TD> tag encloses the table data (a cell value) and 
defaults to left justified text alignment. 
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Task 4 Creating More Complex Tables 
Objectives To create a more complex table in your HTML document. 

Instructions This time you will build a more complex table, and will have to make 
use of options such as COLSPAN, ROWSPAN. 

Comments Read the instructions carefully.  You will build your table gradually 
and view your progress in Netscape. 

 

Activity 4.1 First look at a finished version of the table you are going to build.  

 
 

Notice that the table has 5 rows and 4 columns. Insert an initial table 
template from the Insert Pane with these attributes. Specify a width of 
60% and a border width of 2 pixels 

Activity 4.2   View the initial table in the document window. We need alter the 
definition of the first row to change the cells to be special table header 
cells. In the Code View, change the <td> and </td> tags in the first 
row to <th> and </th> respectively. Thus the first row should look 
something like: 
<tr>� �
� � � � <th>&nbsp;</th>�
� � � � <th>&nbsp;</th>�
� � � � <th>&nbsp;</th>�
� � � � <th>&nbsp;</th>�
</tr>�
  

Activity 4.3   We also need to define the table cells in the first column as header 
cells. To do this change the first column in each row from a <td> type 
cell to a <th> type cell as you did above. For example the second table 
row will look something like: 
<tr>� �
� � � � <th>&nbsp;</th>�
� � � � <td>&nbsp;</td>�
� � � � <td>&nbsp;</td>�
� � � � <td>&nbsp;</td>�
</tr>�
 

Activity 4.4  Now notice that the first column cell in the Neuter column in our 
final table spans two table rows. Thus we will need to use the 
attribute ROWSPAN of the <td> tag to expand this cell in the table we 
are building. Add the attribute ROWSPAN=”2” to the second cell of the 
second row. The second row of your table should now look like this: 
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<tr>� �
� � � � <th>&nbsp;</th>�
� � � � <td� ROWSPAN=”2”>&nbsp;</td>�
� � � � <td>&nbsp;</td>�
� � � � <td>&nbsp;</td>�
</tr>�
�

The expanded table cell now covers the second cell in rows two and 
three. You should therefore remove the second cell from the third row 
as it is no longer required. 

 

Activity 4.5  We now need to change the last two rows, where the second cells 
span three columns. You will use the COLSPAN attribute to do this. 
You will also need to align the text in the centre of these two cells. 
Thus each of your final two table rows will look like: 

 
<tr>� �
� � � � <th>&nbsp;</th>�
� � � � <td� colspan="3"� align="center">&nbsp;</td>�
</tr>�
 

Notice that the last two cells have been deleted as they are no longer 
required. 

 

Activity 4.6 Now you can add text into the relevant cells in the table. The last 
thing to do is to add a caption at the bottom of the table. Do this as 
before, but add the attribute ALIGN=”BOTTOM”,� i.e: 
<table� width="70%"� border="1">�
<caption� ALIGN=”BOTTOM”>Declination� of� <I>is</I>� in�
singular�
</caption>�

Save your HTML page and preview it in Netscape by selecting  
Preview in Browser from the File menu. 
 

Explanation You can nest a number of HTML tags in the CAPTION tag. The 
attribute ALIGN=”BOTTOM” positions the caption below the table. 

 The attributes ROWSPAN and COLSPAN can be used within the 
<TH>...</TH> and <TD>...</TD> tags to force a cell to span more 
than one row or column respectively. 

 The attributes VALIGN and ALIGN can be used in the <TH>...</TH> 
and <TD>...</TD> tags to align cell contents vertically or 
horizontally. 

 The <TH> (header), <TD> (data) and <TR> (row) tags can all contain the 
ALIGN  attribute with values of left,� right and center.  However, 
attributes defined within the <TH> and <TD> tags will override the 
alignment set in the <TR> tag. 
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Task 5 More Optional Attributes for Tables 
Objectives Create a table using text aligning and colour attributes. Learn how to 

develop tables in Dreamweaver using the document window and 
property inspector.  

Instructions You will add alignment and other cell formatting attributes to the 
table, making use of the document window and property inspector 

Comments     The table definition facilities available from the menu bar and 
properties inspector take much of the hard work out of the use of 
tables in HTML. 

 

Activity 5.1 Return to� Dreamweaver.  Create a new HTML document by selecting 
New from the File menu. Click HTML� in the Basic� Page: area. We 
will create step-by-step the table shown below. 

 

Insert a new table into the document from the Insert Pane, with the 
following options:�
Border� width� =� 3�

Rows� =� 6�

Columns� =� 3�

Cell� spacing� =� 0�

Cell� padding� =� 5�

Width� =� 80%�

Activity 5.2 Notice first that the upper-left cell spans two table rows. We need to 
increase therefore the rowspan attribute of this cell. In the Design 
View of the document window, right click on the upper-left cell of the 
table and select Table then Increase Row Span, as shown in Figure 6 
below. 
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Figure 6  Increasing Row Span from the document window 
 

Activity 5.3 Repeat this activity but this time increase the rowspan of rows 3 and 
5 using the same method. Save your HTML page and view your 
progress in the Design View and Code View. 

Activity 5.4 In the final table, the cells which contain text should be defined as 
header cells. We will redefine these table cells using the Design View 
and the property inspector. In Design View select the entire first 
column by pressing the left mouse button down inside the top cell 
and dragging the mouse into the bottom cell. Dreamweaver will 
highlight the column. Your document should look like Figure 7. 
  

 

 
Figure 7  Highlighting table cells 

Now click the Header box in the property inspector. If you cannot see 
the properties window, select Properties  from the Window menu. 
Figure 8 shows the property inspector: 
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Figure 8 The Property inspector 

 

Activity 5.5 Repeat the process described in Activity 5.5,  this time selecting the 
columns 2 and 3 of rows 1 and 2 and redefining these cells as header 
cells. 

Activity 5.6 Select the table cells which appear shaded in Activity 5.1. Using the 
property inspector again, click on the box next to the label Bg (to the 
right of the header box). A Colour selection box will drop down. Select 
the light yellow colour with hexadecimal code of FFFFCC. 

Activity 5.7 Notice that, in our final table, the text is aligned in the centre. Use the 
property inspector to set the horizontal alignment of text to the centre 
for all the cells. (Use the drop-down menu labelled Horz in the 
property inspector.) 

Activity 5.8 The table is now ready for you to add the text. Once you have done 
this, the only thing left is to add the table caption, which is aligned at 
the bottom of the table. Use the Code View to do this. Save your 
document and preview it in Netscape.  

Explanation The attributes CELLSPACING and CELLPADDING can be used within 
the <TABLE>� tag to increase the spacing between the table cells and 
between the border of the cells and their contents.  The table border 
can also be increased. Colour can be added to the table using the 
BGCOLOR attribute. 
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Task 6 Using Tables To Arrange 
Objects On A Page 

Objectives Study the use of tables to define page structure and design. 

Instructions Examine a well known website and learn how tables have been used 
to structure information on the web page 

Comments The use of tables to structure web pages is currently the way most 
web designers arrange their HTML content on web pages. Tables used 
in this way provide invisible skeletons for web pages, and thus border 
width is set to 0. Lessons learnt here will enable you to use tables in 
the same way for your own web page creations.  

 

Activity 6.1 In Netscape, type the URL http://www.leeds.ac.uk/iss into the 
Location: box. This page uses two invisible tables to define the table 
structure. Figure 9 shows the web page you will see in your browser: 

 
Figure 9  The ISS web page 

Now type the following URL into the Location: box in Netscape (or 
Address: in IE): 
http://www.leeds.ac.uk/iss/indexstructure.html� �

This is a modified version of the previous page in which the border 
width of the tables has been set to 3. Thus the invisible skeleton of 
the page is now visible. Figure 10 shows this HTML page. 
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Figure 10 Table structure visible 

 

Notice that table cells in this document contain a number of different 
HTML elements, including hyperlinks, images and imagemaps. 

You can further investigate how tables are used in this way by visiting 
some well known search engines on the web, using the View Source 
option in Netscape to look at page structure.  
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Task 7 Creating Your Own Table 
Objectives To create your own table. 

Instructions Re-create the table below.  You can modify this as you wish.  

Comments You can use any of the HTML 4 tags and their attributes which are 
provided in the list at the end of this document. 

 

Activity 7.1 Return to Dreamweaver and create a new HTML document. Create 
the table shown below. Add a suitable caption to your table and save  
your document in the directory you created in Task 2. 

View your table as you create it in Document Window, and once you 
have finished look at the results in Netscape. 

 

Quantity Ingredient and 
Preparations 

Instructions 

3 lbs. sweet potatoes, baked, 
peeled, and mashed 

 

1/2 lb. (1 stick) margarine  

3/4 cup sugar  

1/2 tsp. allspice 

1 tsp. vanilla extract 
Mix and spread evenly in 
a 9" by 13" pan. 

1/2 tsp. cinnamon  

3/4 cup orange juice  

1.5 cup brown sugar 

1.5 cup chopped nuts (typically 
walnuts or pecans) 

Mix, then spread evenly 
on top of the first layer. 

Bake at 350 degrees (F) for 25 to 30 minutes 
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HTML Tables  
A Quick Reference Guide  

<TABLE>...</TABLE> 

Attributes: align=left,� right� or� center�
bgcolor=colour� name� or� #RRGGBB�
border=integer� value�
bordercolor=colour� � (IE4+,� NN4+� only)�
bordercolordark=colour�  (IE4+� only)�
bordercolorlight=colour�  (IE4+� only)�
cellpadding=integer� value�
cellspacing=integer� value�
hspace=integer� value� � (NN4+� only)�
vspace=integer� value� � (NN4+� only)�
width=integer� value� or� percentage�

<CAPTION>...</CAPTION> 

Attributes: align=top, bottom,� left� ,� right 

<TR>...</TR> (Table Row) 

Attributes: align=left,� right� or� center�
bgcolor=colour� or� #RRGGBB�
border=integer� value�
bordercolor=colour� (IE4+,� NN4+� only)� �
bordercolordark=colour� � (IE4+� only)�
bordercolorlight=colour� � (IE4+� only)�
valign=baseline,� top,� middle� or� bottom 

<TH>...</TH> (Table Header) 

Attributes:� align=left,� right� or� center�
bgcolor=colour� or� #RRGGBB�
bordercolor=colour  (IE4+,� NN4+� only)�
bordercolordark=colour�  (IE4+� only) 
bordercolorlight=colour�  (IE4+� only) 
colspan=number�
rowspan=number�
valign=baseline,� top,� middle� or� bottom�
width=integer� value�
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<TD>...</TD> (Table Data) 

Attributes: align=left,� right� or� center�
bgcolor=colour�
bordercolor=colour�  (IE4+,� NN4+� only) 
bordercolordark=colour�  (IE4+� only) 
bordercolorlight=colour�  (IE4+� only) 
colspan=number�
nowrap�
rowspan=number�
valign=top,� middle� or� bottom�
width=integer� value�

�

Useful WWW Resources 
• HTML Goodies: Table tutorials 
http://www.htmlgoodies.com/tutors/tbl.html�

�

• W3C.org�

http://www.w3.org/TR/REC-html40/struct/tables.html�

�

• Page� Tutor� –� Tables�

http://www.pagetutor.com/pagetutor/tables/�

�

• Available from the ISS Help Desk�

Fur 1 Guidelines for HTML Authors 
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